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Overview 

This user guide describes how the Senturus Analytics Connector is used from Power BI after it 
has been installed and configured. 

Please refer to the Senturus Analytics Connector Installation and Configuration Guide for 
instructions on installing and configuring the Analytics Connector. 

The Analytics Connector is designed for Power BI and has been tested against different versions, 
including both Power BI Desktop and Power BI Gateway on Windows starting with the August 
2018 release. For optimal stability and performance, it is recommended that you keep your Power 
BI software fully updated. 
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Connecting to Analytics Connector Server 

You don’t connect to Cognos directly from Power BI Desktop or Power BI Gateway. Instead you 
connect to the Analytics Connector server and the Analytics Connector server connects to a 
Cognos dispatcher on your behalf. For more information, please refer to the “Architecture 
Overview” section in the Senturus Analytics Connector Installation Guide. 

You can connect to the Analytics Connector Server using either the Power BI built-in SQL Server 
database connector or the Senturus custom data connector. 

Senturus highly recommends adopting the Power BI built-in SQL Server connector. See the 
Legacy Documentation section for information on the custom connector.  

 

Power BI SQL Server Connector vs Custom Connector 

Starting from version 5.0, you can connect from Power BI Desktop and Power BI Gateway to the 
Analytics Connector via a SQL Server database connection. 

If you migrated from version 4.x, you may still use our custom Data Connector to connect. All your 
old reports and data sources will continue working. 

Compared to the custom data connector, the SQL Server connector gives you the following 
advantages: 

1.  No need to install Analytics Connector ODBC client1. 

2.  No need to copy custom Data Connector (.mez files). 

3.  Use Windows authentication from Power BI Desktop to Analytics Connector server to    
Cognos.2 

4.  More Power BI functions are supported, e.g. query cancellation. 

 

See the Legacy Documentation section for information on the custom data connector.  

 

 

1 You still need to install SQL Server Native Client 11 or above on your client computer. 

2 Both Power BI Desktop and Cognos server must be secured by the same Active Directory service. 

https://powerbi.microsoft.com/en-us/blog/tag/query-cancellation/
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Conecting via SQL Server Connector3 

To begin, open Power BI Desktop and select Get Data -> SQL Server from the ribbon. “SQL 
Server database” dialog pops up. 

In Server input box, Type in hostname of IP of Analytics Connector server. 

In Database (optional) input box, type in database name given by your Analytics Connector 
administrator when he/she mapped a Cognos package or data module to it. 

Check DirectQuery and (optionally) uncheck “Include relationship columns” and check “Navigate 
using full hierarchy”. 

The Senturus Analytics Connector supports both Import and DirectQuery modes. For the sake of 
simplicity, we will only use DirectQuery in this section. For more information regarding when and 
how to use Import vs DirectQuery mode, please refer to the next section. 

Then click on OK button. 

 

 

 

 

 

3 Make sure you have installed the SQL Server Native Client 11 or above in order to use SQL database 
connection. The download can be found here: https://www.microsoft.com/en-
us/download/details.aspx?id=50402 

https://www.microsoft.com/en-us/download/details.aspx?id=50402
https://www.microsoft.com/en-us/download/details.aspx?id=50402
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You can use either Windows authentication4 or Database authentication (by providing your 
Cognos login user name and password). 

 

 

NOTE: Power BI desktop will securely store these credentials and skip this dialog if you have 
entered before.   

To manage or delete the stored authentication information, go to File → Options and settings → 
Data source settings. 

You may see a warning popup if SSL is not enabled on the Analytics Connector server. Click OK 
to dismiss this message. 

 

 

 

If your database is mapped from Cognos package, you will see the following objects in the 
Navigator panel: 

1.  Each namespace is mapped to a schema. You will see some system schemas when 
connecting to a real SQL server database. 

 

 

4 You can only use Windows authentication when your Administrators have successfully configured 
Windows Authentication support on Senturus Analytics Connector server. 
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2.  Each query subject is mapped to a table. 

3.  Each query item will be mapped to a column. Plus a dummy column, AAA_LINK, in each 
mapped table. See Creating Relationships regarding more informaton. 

4.  If you have standalone calculations under a namespace, each calculation is mapped to a 
column under a special table AAA_CALCULATIONS (table name is configurable in Data Source 
Configuration tool). You can use this special table the same as other query subject mapped 
tables. 

5.  If you configured schema to report folder mappings, each report will be mapped to a table 
under a schema. However, you cannot use report mapped tables as regular tables, please refer to 
Working with Reports for more information. 

If your database is mapped from a Cognos data module, you will see following objects in the 
Navigator panel: 

1.  Only one schema with the same name as your data module. You will see some system 
schemas when connecting to a real SQL server database. 

2.  Each table in a data module is mapped to a SQL Server database table. 

3.  If you configured schema to report folder mappings, each report will be mapped to a table 
under a schema. However, you cannot use report mapped tables as regular tables, please refer to 
Working with Reports for more information. 

Select only tables you need to pull columns from and click on Load button. 

Hint: You don’t have to wait table preview to be loaded before clicking on Load button. 
Additionally, you can uncheck the Display Options -> Enable data previews option to skip 
previews. 
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Power BI will then inspect the selected tables and load them into a report. 

 

 

 

After loading tables into Power BI, you need to create relationships among tables before building 
report pages. Please refer to Creating Relationships for more information.  
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Import vs DirectQuery Mode 

Differences 

The Senturus Analytics Connector supports both Import and DirectQuery modes. The bottom line 
is the Senturus Analytics Connector sever has no clue if a query is sent for Import or DirectQuery. 

 

Basic Difference 

The basic difference between Import and DirectQuery mode is, Import mode extracts the data 
from your database and pulls it into the Power BI report, while DirectQuery leaves the data in your 
database and sends queries (usually grouped and aggregated) to pull the information as needed. 

Other things to note. Import gives you the full suite of transformation and data manipulation in the 
Desktop, but there is a 1 GB limit to the report if you plan on publishing to the PBI Service. 
DirectQuery leaves the data in your database, so the data will always be live/up-to-date and there 
is no need to refresh. 

 

Performance 

Import is usually faster than DirectQuery, and it reduces your database workload because 
everything is already imported into a Power BI report but this is not always true. Results vary 
depending on your live database performance and the size/structure of imported data. 

 

Security 

When you use DirectQuery, the Senturus Analytics Connector server logs into Cognos on behalf 
of you, so all Cognos securities will be enforced, for example package/report access security, and 
row level security built-in your Cognos model and reports. 

When you use Import mode, Cognos securities will be applied only when you import the data. 
Once data is imported into Power BI, they are disconnected from Analytics Connector/Cognos, so 
all data will be open to anyone that has access to this Power BI report until you set up row-level 
security in your Power BI report. 

 

Relationship Setup 

Whether your Cognos models (FM packages, data modules, cubes) expose primary and foreign 
keys also affects your options of which one to use. If there are no join columns between tables 
(derived Cognos query subjets, hierarchies, etc.), then you cannot join imported tables in Power 
BI. We will dicuss this in detail later. There is some workaround though, please refer to Join 
Tables without Key Columns for more information. 
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Other 

The last difference is, Import mode is only available when you are using the SQL Server 
connector5. 

Import Mode is generally not recommended. It bypasses any Cognos row-level security that’s 
been established so any data access logs and audit trails are either lost or need to be rebuilt in 
Power BI. Relationships are also not as straightforward to make if your Cognos models don’t 
expose primary and foreign keys (See Relationship Setup). Lastly, measures in your Cognos 
DMR models may not work properly when in Import mode. Measures are dependent on the 
aggregation level being applied. When using Import mode, the correct aggregation level cannot be 
deduced and the Connector uses the default aggregation level set in Framework Manager which 
may lead to skewed results.  

If you find yourself needing to use Import mode, the recommended approach is to create a 
Cognos list report that pulls all the data points you need at the appropriate aggregation level for 
your calculations. Once this report is in place, use the RunReport function to use the report as 
your data source. 

 

Composite Mode 

Starging from the December 2020 release, Power BI supports composite models, which means 
you can mix DirectQuery and Import tables/queries in one report. You still need to make sure 
PK/FK are available when joining from/to an imported table/query – otherwise, they have to be 
DirectQuery tables. 

 

Import Tables 

We already showed you how to connect tables via DirectQuery mode in the previous section. 
Importing tables follows the exact same steps, except you need to check the “Import” option. 

 

 

5 You can setup an ODBC DSN using SQL Server native client 11.0+ or Senturus Analytics Connector 
ODBC client, then import tables/queries using Power BI ODBC connector. This is how it works in 
previous release before V5. This will still work, but we recommend you use SQL Server Database 
connector in Import mode for all new reports. 
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Importing Queries 

You can also specify a query to import instead of individual tables. 

Within the “SQL Server database” page, type in “Database” (it’s now mandatory when importing 
a query), and put a valid select script in “SQL statement (optional, requires database)” box. 
You can use standard SQL select statements here, including filter, group, aggregates, functions, 
even sub-queries. We cannot guarantee it will support all select statements, so keep it as simple 
as possible. 

The schema, tables and columns are derived from your Cognos model, as you can see during the 
importing tables page. Also, please use AAA_LINK to join your tables (see screenshot for 
example). 
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After clicking OK, this query will be sent to the Analytics Connector server and a preview page will 
display the result once data is returned. Click “Load” to import it into Power BI report or 
“Transform Data” to do more transformation before loading. 
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Once the query is imported, you click on the “Data” tab to view the data and make more 
transformation as needed. 
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Creating Relationships 

Power BI requires relationships between tables, but Cognos typically does not present primary 
key and foreign keys at the business user view.   

The Analytics Connector injects AAA_LINK columns into the tables so you can build relationships 
between them even when there are no PK/FK columns. The Analytics Connector ignores joins 
formed by AAA_LINK columns when passing queries to Cognos for execution. 

NOTE: It is very important that you create the relationships as described so that Power BI sends 
the appropriate queries to Cognos! 

 

Join DirectQuery Tables 

When joining DirectQuery tables, always use AAA_LINK columns because you want to let 
Cognos decide the correct relationship. Even when you do have business PK/FK columns, please 
still join them by AAA_LINK columns as this will guarantee correct results and better 
performance. 

 

Start by dragging the AAA_LINK column in the fact table to the AAA_LINK table in the dimension 
table. 

 

 

 

In the Create Relationship dialog, make sure the cardinality is set Many to one (*:1). 
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Check the box next to Assume referential integrity. 

Click OK. 

Hint: You don’t have to wait for Power BI to populate preview contents before clicking the OK 
button. If Power BI shows an error dialog because it hasn’t finished probing the tables yet, you 
can simply dismiss and ignore the error, as Power BI will create relationships as you specified 
anyway. 

 

 

 

Repeat these steps until the fact table has relationships to all dimension tables. 

If you have multiple fact tables, chain these fact tables based on granularity and link the highest 
level fact table to dimension tables, as shown in the diagram below. 
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After creating relationships, change to the Report view and create your report. 

 

Join Import Tables 

When joining import tables, always use your business PK/FK columns. Using AAA_LINK to join 
import tables will yield incorrect results. Why? Because once the table/query data is loaded into 
Power BI, they are stored as different tables within Power BI. If you join tables by AAA_LINK 
(which are simply sequential numbers in each table/query), the numbers will be wong. 

 

Join DirectQuery and Import Tables 

When joining between DirectQuery and Import tables, always use your business PK/FK columns 
too. Power BI will query DirectQuery first then join the result to the import table using the 
relationship you defined, so these relationships must be joined by business PK/FK columns. 
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Join Tables without Key Columns 

What if your table does not have business PK/FK columns and you still need to join it with an 
import table, or this table itself is an import table? You can borrow ones from other tables using a 
query. 

You can import a query, and “borrow” FK columns from other tables by using a select statement 
like below: 

select p."Product",  

 y."Month",  

 sum(m."Quantity sold") as "Quantity sold", 

 sum(m."Revenue") as "Revenue", 

 sum(m."Product cost") as "Product cost",  

 sum(m."Gross profit") as "Gross profit",  

 sum(m."Sales target") as "Sales garget" 

from "great_outdoors_sales_en"."Measures" as m 

    join "great_outdoors_sales_en"."Products" as p on (m.AAA_LINK = p.AAA_LINK) 

    join "great_outdoors_sales_en"."Years" as y on (m.AAA_LINK = y.AAA_LINK) 

where  y."Year" = '2010' 

group by p."Product",  

 y."Month" 

 

Then you can join this query to other import tables like below: 
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Cognos Parameterized Tables and Reports 

You cannot use parameterized tables (mapped from Cognos parameterized query subjects) or 
report mapped tables as regular tables. Power BI will not be able to import them if you select any 
parameterized tables or report tables: 

 

  

 

When using parameterized query subjects in a Cognos report, or executing a pre-defined Cognos 
report with prompts, users will be prompted to enter parameter values but you cannot provide 
parameter values in Power BI for regular database tables. 

The answer is to write custom SQL and use OpenTable and RunReport functions to feed 

parameter values to Cognos. 

 

Working with Parameterized Tables 

The Analytics Connector supports working with parameterized tables in Power BI by using the 
OpenTable function, which lets you pass parameter values to Cognos. 

Example: 

select p."Product line", p."Product type", sum(s.Revenue) as Revenue, 

sum(s.Quantity) as Qantity  

from  

  OpenTable ( 

    "Sales (query)"."Parameterized Products", 

    "p_product line code"="[991, 992, 993, 994, 995]",  

    "p_Product Line"="'Golf Equipment'",  

    "p_Date"="{d '2010-01-01'}", 

    "p_Datetime"="'2010-01-01 19:00:00'" 

  ) as p 

  join "Sales (query)"."Sales" as s on (p.AAA_LINK = s.AAA_LINK) 

group by p."Product line", p."Product type" 
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Instead of selecting from a table directly, you use the OpenTable function (a tabular function) to 
invoke the parameterized table and join it to other tables. The first parameter "schema 

name"."table name" is the Cognos table name. This is followed by zero or more Cognos 

parameter name-value pairs separated by commas. For more information, please refer to 
Function Syntax. 

 

To begin, open Power BI Desktop and select Get Data -> SQL Server from the ribbon. “SQL 
Server database” dialog pops up. 

In Server input box, Type in hostname of IP of Analytics Connector server. 

In Database (optional) input box, type in database name given by your Analytics Connector 
administrator when he/she has mapped a Cognos package or data module to it. Please note, 
Database is mandatory in this case. 

Check DirectQuery and (optionally) check “Navigate using full hierarchy”. 

Expend “Advanced options”, put custom SQL in “SQL Statement (optional, requires 
database)” box. 
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Click OK. 

 

 

A data preview window will display.  Click Load. 

 

 

 

You can now use the columns from the Fields tab to build the report. 
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Working with Reports 

The Analytics Connector supports working with Cognos reports in Power BI by using the 
RunReport function, which lets you pass parameter values to a Cognos report. 

The Analytics Connector only supports list style Cognos reports, not crosstabs or charts. 

Example: 

Select *  

From  

    RunReport ( 

        "Connector Reports"."Parameter Report", 

        "p_product line code"="[991,992,993,994,995]", 

        "p_Product Line"="'Golf Equipment'", 

        "p_Date"="'2010-01-01'", 

        "p_Datetime"="2010-02-01 19:00:00" 

    ) as "Report" 

The first parameter "schema name"."report name" is the Cognos report. This is followed by 

zero or more Cognos parameter name-value pairs separated by commas. For more information of 
about RunReport function, please refer to Function Syntax. 

 

To begin, open Power BI Desktop and select Get Data -> SQL Server from the ribbon. “SQL 
Server database” dialog pops up. 

In Server input box, Type in hostname of IP of Analytics Connector server. 

In Database (optional) input box, type in database name given by your Analytics Connector 
administrator when he/she mapped a Cognos package or data module to it. Please note, 
Database is mendentary in this case. 

Check DirectQuery and (optionally) check “Navigate using full hierarchy”. 

Expend “Advanced options”, put custom SQL in “SQL Statement (optional, requires 
database)” box. 
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Click OK. 

 

 

A data preview window will display.  Click Load. 

 

 

 

You can now use the columns from the Fields tab to build the report. 
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Working with Power BI Parameters 

In your Power BI ODBC queries, you can replace the static values with Power BI parameters to 
create dynamic values that can be easily changed.  

After configuring a Parameterized Table or Report query, click Edit Queries to bring up 
the Power Query Editor. 

 

 

Click Manage Parameters to display the Parameters dialog.  

Create a new parameter. 

 

 

 

Next, edit the query to include the parameter in the SQL statement. You may need to format non-
text data types using M language functions in order to append them to the statement. 

 

The below example formats a date parameter to text and appends it to the SQL statement. 
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NOTE: Double quotes must be escaped by using two sets of double quotes. 

 
Click Close & Apply.  
 

 
To change the Parameter value(s), select Edit Parameters under Edit Queries. 

 

The Enter Parameters dialog will display with a list of configured parameters and their values.   

Fill in new values and click OK. 

 

 

 

Click Apply Changes if the data does not refresh. 
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Function Syntax 

Both OpenTable and RunReport functions use the same syntax. 

Syntax 

Both OpenTable and RunReport function use the following syntax: 
OpenTable ( "Schema Name"."Table/Report Name"(, "Parameter"="value", …) ) 

The first parameter is a table identifier, using standard SQL syntax. All identifiers are case in-
sensitive and the schema name can be omitted if the table name is unique across schemas. 

Any additional parameters should be defined as name-value pairs, separated by commas. Name 
and values should be surrounded by double quotation marks. 

Parameters 

Use parameter name in place of "Parameter" for the Cognos connector. 

 
Values 

All values should follow the SQL/ODBC standard. 

Only plain string representation is allowed for numeric values. Formatted representations such as 
1,200.00 with thousand separators, (15) for -15, or 50% for .5 are not supported. 

For string values, single quotation marks are used around the value. For example, 'Golf 
Equipment' or 'Sam''s Club'. 

For date/time/timestamp values, use the ODBC standard format. For example {d '2010-01-01'} or 
ISO 8601 standard format, 'YYYY-MM-DD' for date, 'hh:mm:ss' for time and 'YYYY-MM-DD 
hh:mm:ss' for timestamp. 

An array of values is passed using brackets.  For example: 

• "product line code"="[991,992,993,994,995]" 

The syntax for a Range parameters is represented by a 2 element array.  For example: 

• "YearRange"="[,2019]" – All years less than or equal to 2019 

• "YearRange"="[2015,]" – All years greater than or equal to 2015 

• "YearRange"="[2015,2019]" – Years between 2015 and 2019 

Character escaping 

Certain characters must be escaped.  

For single quotes within a string value, use two single quotes to escape a single quote inside the 
string. 

Double quotes in parameter name and values need to be escaped with two double quotes. 
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Passing multiple values to a parameter 

A Cognos parameter may accept multiple values, for example [Product line code] in (?p_Product 
line code?). To specify multiple values in your function, put multiple values in a pair of square 
brackets ([]) and separate each value by a comma (,) just like CSV format. 
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Publish to powerbi.com 

After creating a Power BI report, you can publish it to powerbi.com and share it with others. 
Simply click on Publish button and select a destination you want to publish. 

In order to allow powerbi.com access to your on-premises data, you need to install and configure 
Power BI Gateway. If you use the custom connector in your Power BI report, you need to install 
Senturus Analytics Connector client on the computer where Power BI Gateway is running and 
copy custom connector file to it. For more information, please refer to Senturus Analytics 
Connector Installation Guide. 

 

To publish a Power BI report from Desktop to powerbi.com, follow steps below: 

1. Connect to the Senturus Analytics Connector server using SQL Server database connection 
or custom data connector. 

 

 

Or 

 

 

2. Create your visualization, save Power BI report, click Publish button. 
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3. Select a destination and click on Select. 

 

 

4. Click on “Open ‘your report name.pbix’ Power BI” in the success dialog: 

 

 

5. You will see an error if you did not setup a gateway using the same connection settings you 
entered in step 1 before. 
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6. Go to the workspace, hover over your mouse right to the newly created data set, and click on 
“More options” button, then “Settings”: 

 

 

7. Click on the arrow button under the Actions column and click on “Manually add to gateway”. If 
you added a data source using the same connection settings, you will see a drop-down list of data 
sources instead of “Manually add to gateway” button. In that case, you can select a data source 
for your dataset without creating a new data source. 

 

 

8. Now you can create a data source under a particular gateway. 

If you are using the SQL Server connector in your report, you can create data sources just like 
you do for other SQL server data source except that you have to pick Basic “Authentication 
method”. 

 Here is an example: 
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If you are using the custom connector, you need to select “Senturus Analytics Connector” from the 
Data Source Type list. Here is an example 
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Please note, you need to type in the exact server, port and database here as you have in Power 
BI Desktop (case sensitive). Please refer to step 1. 

9. After creating data source, go back to data set settings, map the data source and click on 
Apply. 
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10. Finally, you can open your report and/or create new reports with your dataset. 
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Legacy Documentation 

This section is for the custom connector. While the custom connector is still supported, Senturus 
highly recommends using the built in SQL Server Connector.  

 

Install the Custom Connector 

Our custom Data Connector wraps the Analytics Connector ODBC client and enables DirectQuery 
capabilities. 

To use the custom Data Connector, follow steps below: 

1.  Install Senturus Analytics Connector ODBC client. The latest ODBC client can be found at 
Senturus Analytics Connector - Customer Resources.6 

2.  Copy the Custom Data Connector “SenturusAnalyticsConnector.mez” from Analytics 
Connector server (under “<install_root>\Power BI” folder) to you Power BI Desktop computer 
(under “{User}\Documents\Power BI Desktop\Custom Connectors” folder). 

If your Senturus Analytics Connector server administrators made some changes using Senturus 
Data Source Configuration tool or Service Configuration tool, for example mapped a new 
database to a Cognos package, or moved Analytics Connector server to a new host, a new 
“SenturusAnalyticsConnector.mez” file will be generated and you need to copy it again. 

3.  Start Power BI Desktop, go to Files -> Options and Settings -> Options, select Security on left 
panel, and under “Data Extensions” option, check “(Not Recommended) Allow any extensions to 
load without validation or warning.” You need to restart Power BI Desktop. 

  

 

 

6 ODBC client is automatically installed when you are installing Senturus Analytics Connector server. So, 
you don’t have to install ODBC client separately on the same computer. 

https://www.senturus.net/connector-download/
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Connect via Custom Connector 

Before using this connector, make sure you followed instructions in the Install the Custom 
Connector section. 

To begin, open Power BI Desktop and select Get Data. 

Find the Senturus Analytics Connector in the list. 

Click Connect. 

 

 

 

Power BI will display a dialog where you can select the Server, Port, Database, and Data 
Connectivity modes. 

The Server, Port and Database lists are pulled from the configuration information in the 
DataSourceConfig.xml file under the server’s Analytics Connector installation folder. 

For the Data Connectivity mode, select DirectQuery.   

Click OK. 
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An authentication dialog will appear.  Type in your Cognos credentials, then click Connect. 

 

 

NOTE: Power BI desktop will securely store these credentials and skip this dialog if you select the 
same Server and Database in a future connection.   

To manage or delete the stored authentication information, go to File → Options and settings → 
Data source settings. 

Once connected to the Senturus Analytics Connector data source, the Navigator window will 
display. 

Select the tables you wish to include. 

Click Load. 
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Power BI will then inspect the selected tables for column information. 

 

 

 

When complete, navigate to the Relationships view and creaste relationships among tables. 
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Contact Us 

The latest version of the Analytics Connector along with related documentation and contact 
information can be found at https://www.senturus.net/connector-download/. 

If you have any additional questions, please contact us at CustomerSupport@senturus.com.  

https://www.senturus.net/connector-download/
mailto:CustomerSupport@senturus.com

